Introduction

This article will describe how to resolve the issue of importing swagger.json file of Stratis Full node blockchain network while importing to the Postman. Additionally, it will explain the steps to upgrade the Postman version from lower to major update.

Problem Statement

I was following the article Write Your First Smart Contract On Stratis Blockchain and faced issue with Postman. I was trying to import swagger.json file of Stratis full node but got the error: “failed to import data: format not recognized”.

Resolution

Later on, I found that I need to upgrade the version of Postman. Stratis Blockchain Full Node Swagger.json file doesnot recognized as valid format if we use older version of Postman. So, the solution to this issue is to upgrade the Postman from lower version to the upper one. I upgraded to version 8.6.2, and I was able to import the Swagger.json file without any issue.

Postman Upgrade Steps

Follow below steps to upgrade Postman version.

Click on Setting icon as depicted below and then again click on Settings.

Go to Update tab and click on Download update. Here, if you scroll down, you can see current version of your Postman and upper version of Postman with bug fixes in the list.

If you directly click download without enabling the Automatically download major updates, then it will update to upper version than the latest version which may not be the major update available currently.

For example, if I click on Download update then my current version of Postman is V6.7.4 and it will be upgraded to 7.36.6 which is upper than current one but not the major version (major version at the time of this article writing is v 8.7.0.

So, enable the major update download option and then click on Download update as illustrated below.

Download may take few minutes, wait until it completes.

After completion of download you will get Message box to Restart Postman and Install new update as shown below. Click on Restart and Install Update.

Then, it installs new update and prepare your workspace.

After the update of Postman, you can import swagger.json file of Stratis full node.

You can then go to your Writing your First Smart Contract On Stratis Blochachain article from here and follow your remaining steps.

Conclusion

To sum up, we have learnt to resolve the issue of version mismatch while importing Stratis Full node swagger.json file to the Postman. Additionally, the article has described the steps to upgrade Postman version with all necessary steps. I hope, this help you to resolve issue of importing Stratis full node swagger.json file to the Postman due to lower version while writing your Smart Contract.

Leave a Reply

Your email address will not be published.